Greasemonkey mostly not working - help?

DiscussãoHacking LibraryThing

Aderi ao LibraryThing para poder publicar.

Greasemonkey mostly not working - help?

Este tópico está presentemente marcado como "adormecido"—a última mensagem tem mais de 90 dias. Pode acordar o tópico publicando uma resposta.

1jjmcgaffey
Ago 10, 2014, 1:34am

I had to do a reset of Firefox (well, I thought I had to...) and lost all my scripts and extensions, of course. I reinstalled Greasemonkey, and copied my scripts over from the old profile. They look fine, they say they're working - and only three seem to do what they're supposed to. Another one works halfway. The others do nothing at all. I uninstalled and re(re)installed Greasemonkey, and found userscripts-mirror.org and installed the scripts from there - same thing.

Am I missing something? Is there a magic switch I haven't turned on? I've tried it with Java and Javascript toggled off (failed completely), with Javascript on (worked as described above) and with both on (no difference). What else?

The three that work are Add Worldcat on Add Books Page, Sort and Re-Link on Combine/Separate pages, and Group Links on Talk Page.
The one that half-works is LT Copy Book - I get the buttons on Book Details, I click one and the Manual Add page opens...and that's it. Nothing copies.
Sort Author Works, Named Styles and Work Edition Grid 2 do nothing whatsoever - GM says they're running on the appropriate pages, but I don't see the links for Sort Author Works, the grid doesn't show up, and I don't see the field to add a name on the Edit Views page (that's where it was for Named Styles, right?)
And most importantly - Cover Navigation 2 does nothing. If I click on an Amazon cover, it warns about changing the ISBN rather than offering to grab; if I click on Information, I don't get the carousel in the top right; etc. Oh! And that may have been the source of the problem that made me reset - I couldn't see covers on the cover page, it just showed the spinner forever. So this one has extra problems.

I also used to have Worldcat Direct Link, Autocomplete Tags, and More "editions" Links. Those aren't brightcopy's (as far as I can see) and I can't find them on the mirror site.

I don't understand why they aren't working - they were fine before the reset. I'm on FF31 now. Any suggestions?

2macsbrains
Editado: Ago 11, 2014, 1:49am

I having many of the same issues, but I'm also on a new operating system, so who knows what is messing up what. I've had all these extra goodies installed for so long that I often don't remember which features are native to LT and which aren't until I try to do something and it doesn't work the way I remember.

I do have the worldcat links working which I think is from here: http://www.librarything.com/topic/82389#1724981 (also see #60, #61 and #65 for the more editions and other worldcat link). I'm assuming you went through that thread already, but just in case you didn't.

As for the tag autocomplete, I think that was omargosh? Yeah, it's here: http://www.librarything.com/topic/165510#4610415

(Unless you meant you can't find them mirrored, in which case I don't know :( I managed to re-install before userscripts went away)

Edit: Yes, that is what you meant, and I'm having 2 a.m. reading-comprehension-fail. I should probably sleep.

3jjwilson61
Ago 11, 2014, 9:31am

There was a report somewhere about a cover script by brightcopy not working but I don't have time to look for it now.

4jjmcgaffey
Ago 12, 2014, 2:05am

I bugged that I couldn't see covers on the cover page, and...someone... discovered that the problem was brightcopy's Cover Navigation script. But I had done the reset just before he(?) posted about that - bah. That may be what you're recalling.

5rosalita
Ago 19, 2014, 12:05pm

I use TamperMonkey in Chrome, and I have had sporadic issues with the Group Links on Talk Page script. Sometimes they show up and sometimes they don't. I haven't had occasion recently to use the few other scripts that I have installed (Copy Book and Autocomplete Tags), so I'm not sure if they're working or not.

6jjmcgaffey
Ago 19, 2014, 1:48pm

The Group Links is the one that always works - I've had no problems with that (thank goodness, I love that one!). That one I remember is a script. Several of the others I don't realize that the problem might be the script, it's just the way LT works, isn't it? :D

7Collectorator
Ago 19, 2014, 4:22pm

I made this post http://www.librarything.com/topic/152693#4681628 on May 9. I don't think brightcopy works here anymore.

8jjmcgaffey
Ago 20, 2014, 1:53am

Actually, he mentioned somewhere that he's kind of disgusted with LT at the moment and not doing much. So that may be it. (Never worked here - but used to play!)

9Collectorator
Ago 20, 2014, 3:01am

It was a joke.