Grease Monkey Library Thing Work Editions Grid

DiscussãoHacking LibraryThing

Aderi ao LibraryThing para poder publicar.

Grease Monkey Library Thing Work Editions Grid

Este tópico está presentemente marcado como "adormecido"—a última mensagem tem mais de 90 dias. Pode acordar o tópico publicando uma resposta.

1Collectorator
Fev 6, 2015, 2:45pm

Please help. I am lost without this script. It doesn't work anymore. I really need it.

Any advice on what to do?

Any idea why it stopped working?

2timspalding
Fev 6, 2015, 3:04pm

What is it supposed to do?

3Collectorator
Fev 6, 2015, 3:06pm

It takes the editions information and provides the ISBN number and sets it all in a sortable grid. You get the title, author, ISBN, number of copies all sortable by whichever one you want. It is fantastic.

4lorax
Fev 6, 2015, 3:07pm

Here's the original thread from when it was introduced.

5JerryMmm
Fev 6, 2015, 3:08pm

it worked on the Improve Author page, right? or also on the Editions page?

6Collectorator
Fev 6, 2015, 3:25pm

>5 JerryMmm: noo, it was just the editions page.

7AnnaClaire
Fev 6, 2015, 5:13pm

>3 Collectorator: "It is fantastic."
Can confirm.

8jjwilson61
Fev 6, 2015, 5:15pm

Tim must have made a change to the Editions page.

9Collectorator
Fev 7, 2015, 3:13am

>5 JerryMmm: The one you're talking about is called LT Sort Author Works and it has also stopped working.

I desperately need both of these.
I really hope that it has something to do with the recent code tweaking on that display recommendations feature. I do know that there are header bars missing on pages.

10jjmcgaffey
Mar 7, 2015, 8:28am

Shimmin did a fix to the Copy Books script (the one that lets you copy everything from a book into the Manual Add page), which worked very nicely. This _may_ be the same thing; if so, it's an easy fix. http://www.librarything.com/topic/115928

However, while I promised to put up the modified Copy Books script, and try the fix on other scripts, I haven't had time to do anything about it yet. Anyone else got a little more time on their hands?

11omargosh
Ago 10, 2015, 3:12am

Ok, so I posted what I think is a "fixed" version of the Work Editions Grid script here: https://greasyfork.org/en/scripts/11603-librarything-work-editions-grid

I don't know if you'll have to uninstall the previous version for things to work properly. Anyway, let me know what problems you find with it. I didn't use it in the past, so I don't know if it's missing any features or has other inadvertent bugs. It now has columns for the new media and entry format stuff.

Good night for now.

12henkl
Ago 10, 2015, 3:33am

I installed the script after removing the older version. Unfortunately, it doesn't work.

13Collectorator
Ago 10, 2015, 10:00am

I installed and it does work. I am so happy. Thank you so so so much, omargosh. Now I am back in business! :D

14omargosh
Editado: Ago 10, 2015, 10:20am

>12 henkl: Well, that's no good. :-) I tried uninstalling it, and installing it again from GreasyFork, and it still worked for me. I also disabled my other scripts in case there was a conflict, but I don't know which scripts you're using (perhaps temporarily disable any others you currently have on "editions" pages?). (Edited to add: I think it created some conflicts for me with a locally altered version of the "Sort and Re-Link on Combine/Separation pages" script.)

Otherwise, a few questions, then. What browser are you using? What URL were you trying?

15omargosh
Ago 10, 2015, 10:14am

>13 Collectorator: Glad it worked for you, Collectorator. Let me know if you run into issues with it.

16henkl
Editado: Ago 10, 2015, 6:00pm

>12 henkl: Disabling all my other scripts didn't help. I'm using Firefox 38.0.5 on OS X 10.9.5. On Windows 8.1 I have the same problem with Firefox 39.0.3.
I installed the script in Chrome (both on OS X and on Windows) and found that it worked alright there!

17macsbrains
Ago 10, 2015, 5:58pm

Alas, no go for me either. I uninstalled everything else out of my scripts page.

Firefox 39.0.3, Windows 8.1

18omargosh
Ago 11, 2015, 11:13pm

>16 henkl:, >17 macsbrains:: Shucks. I seem to be able to get it working on FF, Chrome, and Opera, but on Windows 7, and I don't have access to a Windows 8 machine, in case that's making the difference. I might be able to test on my brother's Mac at some point.

I'm not sure what's causing the problem, so maybe try a few things for me to help debug? 1) Maybe first see if this newly updated script works or not for you? and/or 2) Open your local copy of the script and make sure that it's the latest version (it should have a greasyfork URL in the @namespace line)? and/or 3) Are there messages showing up in the Error Console when you load an /editions page? (PM me if you need help with any of these. Thanks!)

19macsbrains
Editado: Ago 11, 2015, 11:40pm

>18 omargosh: Alas, still no-go. I will try it at work when I get the chance (I run Win 7 and Vista there) but that probably won't be until later this week.

If the problem is 8.1 then I'll just live with it not working. I'm using one of those laptop/touchpad combo things and 8.1 can't even get the touchpad to work correctly without it dropping the connection and forcing me to pretend to detach and reattach it. 8.1 is a lost cause.

20henkl
Ago 12, 2015, 4:25am

Still not working; it cannot be just a Windows 8.1 problem, it's also on OS X 10.9. Later this week my wife's notebook will be upgraded to Windows 10; then I'll try it again.
1. this script works for me.
2. it's the latest version indeed.
3. no messages.

21macsbrains
Editado: Ago 12, 2015, 10:32pm

omargosh was kind enough to work with me to debug the script.

jjmcgaffey in post 10 made reference to some changes that were made to Brightcopy's old copy manual editions script, so thinking along those lines, this is the fix that ended up working for me:

Add the following to the top of the script under the inclusions:

// grant GM_addStyle

Thanks again, omargosh !

22omargosh
Ago 12, 2015, 10:34pm

>20 henkl:, macsbrains helped me w/ debugging, and we think it was just missing a line. So maybe try installing the new version? Same URL as before: https://greasyfork.org/en/scripts/11603-librarything-work-editions-grid

23jjmcgaffey
Ago 12, 2015, 11:05pm

Those grant things are being rather a pain! Useful, and more secure (like Android explicit permissions) but sheesh.

24Collectorator
Set 9, 2015, 12:43pm

>15 omargosh: This may be related to the work on covers and whatnot that Tim is doing, but clicking on an ISBN takes me to an empty search every time.

25omargosh
Set 9, 2015, 4:11pm

>24 Collectorator:
Hmm, yeah, even if I just use the search box from the top of the page, it seems like ISBN searches aren't working. Maybe they are messing with search stuff right now?

26Collectorator
Set 9, 2015, 6:00pm

>25 omargosh: wouldn't be surprised. thanks for confirming. It's not your hack, it's Tim's!

27Collectorator
Nov 26, 2017, 9:22pm

I must ask for help again. Firefox hosed itself, which made my Greasemonkey stop working. I downloaded Chrome and Tampermonkey, but cannot seem to find the Editions Grid script. There are dire warnings all over saying places have been hacked, etc. so I'm hesitant to download a script anyway.

Any help?

28Collectorator
Nov 26, 2017, 9:26pm

Wait! I have no idea how but it suddenly started working!!! :D