CueCat not bringing up correct titles

DiscussãoCueCat questions and help

Aderi ao LibraryThing para poder publicar.

CueCat not bringing up correct titles

Este tópico está presentemente marcado como "adormecido"—a última mensagem tem mais de 90 dias. Pode acordar o tópico publicando uma resposta.

Jun 12, 2010, 8:54pm

I just tried using my CueCat for the first time today. When I scan a barcode it shows gibberish, which I understand to mean it isn't "declawed". (It does this both in a text document and in the LT search box.) That's Ok with me but it isn't giving me usable results. With some books I tried, it found nothing in any of the sources (Amazon, LC, etc.) With others it gave me lists which started with a totally irrelevant title and then included unrelated books already in my collection. When I search by ISBN all the titles I have tried have appeared promptly. Since I am working with paperbacks I also tried the bar code inside the front cover but got the same bad results. Ditto with hardcovers: for one hardcover it showed me two totally wrong titles. I'm using an iMac G5 Running OS X 10.5, if that makes a difference; my keyboard has a separate number pad as well as numbers across the top, and no Num Lock key. I love LT and would like to put my 4000+ collection into it, and I love the idea of CueCat. Can you help me get it to work?

Jun 13, 2010, 4:25am

Can you give some details? Copy and paste the gibberish from a CueCat swipe of a couple books, and give their ISBNs. It sounds like your Cat isn't actually reading the ISBN (you know, I think, that the bar code on the back isn't necessarily the ISBN? If it doesn't start with 97 (978 or 979), it's a different code.) but I'm not sure about that, so I'd like to see what it is putting up. There are websites that talk about the encryption and show the proper gibberish for different kinds of codes - here's the best one.

Jun 13, 2010, 2:56pm

Thanks for any help you can give! Here are 4 items for which I got the message "No results for ..." when using CueCat but which I found easily by typing in the ISBN. Two have older ISBNs from before they added the 97- prefix because they were running out of numbers. If CueCat can't handle older books it won't do me much good :-(

ISBN 978-0-425-22828-9

isbn 0-571-19823-6

isbn 0-965-46277-3
Isbn 978-0-316-73495-0

Jun 15, 2010, 2:26am

I think you got the Cat scans and the ISBNs mixed up a little, but the real problem is that only one of these scans is of an ISBN - the third scan (which actually matches the ISBN in the second pair) - worked fine for me (I just copied and pasted the CueCat scramble, and got The Loop by Joe Coomer - same as the second ISBN (the 0-571 one)). Try it with copy-and-paste, then try again with the Cat and see what happens.

I think the bar codes you're scanning are mostly UPCs rather than ISBNs. Looking at these four, the third one has .cGf2. in the middle - that indicates an ISBN. The other three have .cGen., which is something else (I assume UPC, since that's the other bar code usually found on books). If the number directly under the bar code a) doesn't start with 97x or b) doesn't match the number labeled ISBN that's usually found just above the code, then it won't be useful to scan it - go for the one inside the front cover instead.

But while that may help with the 'no results' problem, it doesn't explain the random results. If you come up with another one or more of those, please post that code - I may be able to figure that one out too.

One possibility, especially if copying The Loop's scramble works for you and scanning it doesn't, is that something on your computer is responding to the Alt-F10 keystroke that the Cat sends before it outputs its scan, and somehow scrambling the scramble so different numbers come out. You might try hitting - hmmm. That's the Windows alt - I'm not sure what that equates to on a Mac keyboard. It might be the Apple key, rather than the one labeled Alt. But try Apple-F10, Option(alt)-F10, and Command-F10 and see if any of them might be scrambling the CueCat's output.

Jun 16, 2010, 5:04pm

Thank you for your helpful answer. The copy/paste of The Loop worked, so you're probably correct that my Mac is sending a different code. But none of the combinations you suggested work; two of them send the same string as before and one substitutes different characters but still doesn't bring anything up. Years ago I had a cheat sheet for converting Windows keyboard commands to the Mac but I can't find it right now, and my current Mac manuals don't give that information, probably because of the emulation software that's now available.

Do you think it would work if I ran WindowsXP, which I have installed for use with a specialized program? The problem is I don't think I have a browser for that (unless it came as part of the Windows program). I will rummage around and see if that works.

I'm not sure which books I tested the first time, which gave me the randomly incorrect answers. If I can duplicate that result I'll post it.

Gratefully, Mary

Jun 16, 2010, 5:17pm

When I input the isbn for "Promise Me" by Harlan Coben (isbn 978-0-525-94949-7) it comes up with no problem.

When I scan it with cuecat, this is the scramble:

When I copy-paste that string it brings up the correct title.

When I use cuecat directly in the Add Books search box, I get two federal government publications and a totally different novel with the isbn 0736908552.

If you can figure that out I'll really be impressed :-)

Jun 16, 2010, 5:44pm

I just tried using WindowsXP, which did come with Internet Explorer. Besides being infernally slow (cuecat kept going to sleep while I waited for pages to load) I got the same bad results for Promise Me and the same message about there not being a match for The Loop. So it has to be something about the Mac keyboard -- I understand that cuecat acts like a keyboard and it must be sending Mac commands.

I'm really bummed by all of this. Even if we figure out a way to get cuecat to work, it seems like it still won't scan my older books, i.e. from before they started using 97- isbns. Will LibraryThing let me return it?

Jun 16, 2010, 11:17pm

Well, the easiest fix is to neuter your CueCat - then it stops sending special data and just sends numbers, so it works with any keyboard. It really is easy - it feels scary to go cutting around inside your Cat, but it's actually quite hard to go wrong, as long as you're cutting the correct pin of the chip. Look at the instructions here and give it a try.

As far as I know, there's no difference to the Cat on older or newer barcodes. But I've never really worked with an unmodified one - I neutered mine as soon as I got it, and I've neutered two more since to give as gifts.

I suspect you can return your Cat just fine - Tim has previously sent a replacement Cat when the original one didn't work. But I really would try neutering/declawing it first, it solves a _lot_ of problems.

Jun 17, 2010, 12:31am

I'm going to be gone over the weekend for a conference but I'll screw up my courage and try the neutering procedure when I get back. Thanks again for your helpful responses. I'll let you know what happens.

Jun 17, 2010, 2:23am

We've been thinking we'll start neutering them ourselves—maybe add a few bucks for our efforts. It's really very simple, especially when you do a bunch.

Jun 17, 2010, 3:58am

Sounds like a good idea to me. So many of the problems are related to the Cats being un-neutered...

Jun 22, 2010, 11:31am

The same thing is happening to me. It was just working 10 minutes ago. I tried to scan the same books that worked before and NOW IT'S NOT working. What could be wrong?

I would type in ISBN and the book would come up. If I scan it, it would NOT BE FOUND or a list of wrong titles will come up. It just worked before.......Help!

Jun 22, 2010, 1:28pm

Sent a note to Casey. I'm thinking it's related to a change he just made.

Jun 24, 2010, 10:17am

I've been messing with the CueCat and discovered a trick that works for me! It doesn't read the ISBNs or brings up lots of random titles when I have my laptop on CAPS LOCK, but when I turn it off, it scans just fine. So try that and see how it goes. Good Luck! :)

Fev 1, 2011, 5:39pm

My apologies for not getting back to you for so long. I never got back to my CueCat problems last summer and only today, because I want to add a lot of titles at one time, decided to try to neuter my Cat. With my husband's help we successfully followed the directions and my Cat is now working great. Thanks again for your help and support!

Fev 1, 2011, 8:59pm

Glad to hear it. I still have no idea what was going on, but yeah, a neutered CueCat is much simpler to use.

BTW, have you noticed that you now have a barcode scanner? I track my kitchen consumables as well as my books...